Find the Runner-Up Score Solution

Find the Runner-Up Score Solution

Given the participants' score sheet for your University Sports Day, you are required to find the runner-up score. You are given  scores. Store them in a list and find the score of the runner-up.

Input Format

The first line contains . The second line contains an array   of  integers each separated by a space.

Output Format

Print the runner-up score.

Sample Input 0

5

2 3 6 6 5

Sample Output 0

5

Explanation 0

Given list is . The maximum score is 6, second maximum is 5. Hence, we print 5 as the runner-up score.

Solution

if __name__ == '__main__':
    n = int(input())
    arr = [int(i) for i in input().split()]

arr = set(arr)
arr.remove(max(arr))
print(max(arr))

Subscribe to The Poor Coder | Algorithm Solutions

Don’t miss out on the latest issues. Sign up now to get access to the library of members-only issues.
[email protected]
Subscribe